ROUTAGE AUTOMATIQUE SOUS P-CAD 2001 I

DOCUMENT ELEVE

© Saisir le schéma sous PCAD-2001 Schématic

Attention : ce schéma est destiné a servir de base a la réalisation d’une carte imprimée.

® Tout ¢lément devant figurer sur le typon ( connecteurs, points test ... ) doit apparaitre comme un
composant sur le schéma structurel.
Donner au fichier un nom de 8 caracteres maxi, sans espace ( compatible DOS )

® A chaque composant doit impérativement €tre associée une empreinte choisie dans une bibliotheque
d’empreintes.

@ ‘Labeliser’ les équipotentielles ( nets ) particuliéres

Lors de la phase ‘Préparation au routage’, il sera nécessaire d’indiquer au logiciel de routage la largeur
des différentes pistes correspondant aux équipotentielles du schéma.

Afin de préparer ce travail, au vu du schéma, REFLECHIR :

- choisir une largeur standard de piste qui sera utilisable pour la plupart des nets.
Exemple : 0,6 mm ou 0,8 mm ou 1 mm

- 1identifier les nets particuliers qui seront routés avec une largeur de piste différente de la

largeur choisie comme standard.
Exemple : alimentations, masses, puissance...

5 Placer sur ces nets particuliers un label ( nom ) qui permettra de les identifier facilement par la
suite.

© Sauvegarder et créer la netlist

Le fichier netliste est un fichier texte comportant toutes les informations utiles pour le logiciel de routage.
On lui donnera le méme nom que le fichier schéma mais avec 1’extension .NET.
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Pour créer la netliste utiliser la commande :
Utils 2 Generate Netlist

Metlist File
= Cliquer sur Netlist Filename, choisir le Dans [ & Répetoie do avail Acoel < ﬁl
répertoire de sauvegarde et entrer le nom du
fichier (voir exemple ci-contre ) 2> Enregistrer

Mom : Ie:-temple Enregiztrer I
Tupe: |Netlist Files [*.net) j Annuler |

 Choisir le Netlist Format ACCEL ASCI
> OK

C:\Répertoire de travail Accelvexemple. net

Metlist Farmat: IACEEL ASCI ) vl ¥ Include Libramy Information

QK. | Cancel |

Le fichier netliste est alors créé. Si une fenétre d’erreur s’ouvre, corriger et recommencer la procédure.

&5 Ouvrir le logiciel P-CAD PCB a I’aide de la commande d’Accel Schéma Utils > P-CAD

PCB

O Préparation au routage sous P-CAD PCB

&5 Créer un cardre au format A4 :
File = Open => Trouver le répertoire C :\Program Files\P-CAD 2001\Titles\ =>» Sélectionner le
fichier « Title_a4.pcb » = Cliquer sur « Quvrir »

&5 Enregistrer votre fichier sous un nouveau nom :
File =>» Save As... = Trouver le répertoire de sauvegarde =» Taper le nom du fichier =»
Cliquer sur « Enregistrer »

&5 Vérifier que les bibliothéques sont chargées :
Library - Setup - La liste ouverte doit comporter la ou les librairies désirées > OK

Pour ajouter les bibliothéques manquantes ou une nouvelle bibliothéque : Add = Choisir la bibliothéque
- Ouvrir

&5 Charger la netliste :

Utils - Load Netlist > Netlist Filename > Choisir le fichier .net > QOuvrir > Veérifier le Netlist
Format : ACCEL ASCII > OK

Les empreintes des composants doivent apparaitre dans la partie gauche de 1’écran.
Une fenétre intitulée Warning 5627 apparait généralement: répondre NON a la proposition de
visualisation (sauf's’il y a des erreurs ! ).
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En cas d’échec, il faut relever les erreurs et les corriger. Il s’agit le plus souvent :
- soit d’une bibliothéque manquante
- soit d’un probleéme de correspondance entre les noms des broches du composant sur le

schéma et sur son empreinte.
& Enregistrer le fichier et effectuer des sauvegardes réguliéres

File > Save As = Entrer le nom ( ce fichier a l'extension .PCB ) > Enregistrer
&5 Vérifier que les unités sont en millimetres ( mm ) :

Option > Configure - Units 2> mm validé > OK

L’¢écran se présente alors de la manicre suivante : ( circuit exemple )

|:* P-CAD 2001 PCB [6/400] - [Chargeur. pcb]
E File Edt “iew PFlace Boute Optionz Library  Utls DocTool Maco window  Help

=18 %]
Rt e

IBRECEREEEREER
i oon

[26670  [7agen [ aps]|[1.270 =l[Ml|feoton =] i:lﬂI'I.EIDDmm -||
L

A 4 | S
Coordonnées curseur Pas de la grille Couche sélectionnée Largeur de piste
Mode curseur ( relatif ou absolu ) par défaut

Les interconnexions entre les composants apparaissent : I’ensemble est appelé le CHEVELU.

é_Le curseur : il est intéressant de le placer en [T

mode relatif et de sélectionner le point | gijsnacing Visible Grid Style
d’origine 0.0. Pour cela se placer dans le menu | 35 £dd & Dotted
v Wizible =
Grids: Delete | " Hatched

Options > Grids > Valider les options ci- | [g3s
contre > OK > Cliquer au point choisi | [1.27
comme origine

— Relative Grid Crigin— Mode

" Absolute
s IEI.DEImm

i+ Relative

M IEI.DEImm
[+ Erompt for Origin

Cancel |

Vérifier I’affichage en bas de I’écran
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¢ La grille : on peut choisir le pas de grille & ’aide de la boite de dialogue ci-dessus afin de définir les
pas possibles puis le choix s’effectue grace a la fenétre placée en bas de 1’écran.

¢ Les différentes couches : le logiciel peut travailler sur différentes couches.

Attention ! : toujours penser a vérifier la couche active ( fenétre en bas de I’écran )

A savoir :

Couche TOP : Face ‘COMPOSANTS’ couche ‘cuivre’, c’est a dire couche sur laquelle on peut tracer des
pistes cuivre, ( a utiliser uniquement si le circuit imprimé est double face )

Couche BOTTOM : Face ‘CUIVRE’ couche ‘cuivre’ ( couche utilisée dans le cas d’un circuit simple
face)

Couche TOP SILK : elle sert a la sérigraphie c6té composants ( couche utilisée pour obtenir le plan
d’implantation des composants )

Couche BOARD : elle servira a tracer les limites du circuit imprimé ( indispensable pour le routage )

Meéthode de travail : on va tracer un cadre correspondant aux dimensions du circuit imprimé. Dans ce
cadre on va placer les composants de la fagon la plus judicieuse possible. Ensuite on donnera au logiciel
les indications nécessaires pour le routage ( nombre de couches, largeurs des pistes, isolement ... ). Puis
suivra le routage proprement dit.

&5 Vcérifier la connexion correcte des composants polarisés ( diodes, transistors, condensateurs
polarisés ) : pour cela zoomer sur le composant jusqu’a apparition des n° de broches et nom des nets.

&5 Tracer les contours de la carte :
® Se placer sur la couche BOARD
® Place > Line = Suivre les indications de la fenétre en bas de ['écran = Touche droite de la souris
pour valider ou bien l'icone : N]
Le contour doit apparaitre dans la couleur de la couche Board ( bleu clair )
Attention ! : le contour doit étre parfaitement fermé et sans recouvrement.

&5 Placer les composants ( judicieusement ! )

Pour cela, valider I’outil de sélection : [ | en haut a gauche de 1’écran.
Sélectionner puis ‘tirer’ le composant

A savoir : commandes clavier R pour tourner le composant
F pour faire subir un effet ‘miroir’ au composant
+ pour agrandir la visualisation ( zoom avant )
- pour diminuer ( zoom arriere )
commande menu View -> Extent pour un affichage entiérement sur I’écran

&5 Placer les composants supplémentaires ( exemple : vis de fixation )

&5 Définir la ( ou les ) couches de routage :

Options - Layers = Configurer de maniére a obtenir [’écran ci-contre = Close

pcad 2001 4



Cette configuration correspond a un routage simple

face . Layers Sets Titles
A Current Laper: Layper Mame: IEF

!Bnttnm LI

J4 s 17 . L. MNumber: |2

La couche TOP est dévalidée ( Disable ) i =

Layers | Type | Mumber | Line Colar: u

Top Assy NE 10

Top Silk NE 0E

Top Past NE 0g =T

ﬁﬁ Mack NE 0 e _ e |

Bettom SEA 2 C Plans e I

Bot Mask NE 05 =

BE{ F‘:sste NE 09 il Delete I

Bt Silk. NE o7 —Routing Bias—

Bt A NE 1

i NE 03 ' Aulo __Ende |

., ¢~ Horizontal =
La couche BOTTOM est autorisée en routage (Enable) ¢ atica )
Enable Al I

Remarque : la couleur attribuée aux couches dépend b W _Obelle |
de la configuration du logiciel sur le poste.

&5 Définir la largeur des pistes et I’isolement

Place Attribute [ x|
Edit > Nets 2> Set All Nets > Edit .
- X Attribute Categony: Mame: Mame:
m 2 ﬂ 2 Sélectionner Al Attributes [uzer-defined) |Width
Uattribut Net Width et entrer la Companert Optirmize ,
si o —
largeur choisie pour les nets par Clearance 0.mml
’ . . auter
défaut ( voir exemple ci-contre ) > | |SPECCTRARoue
OK SPECCTRA Placement
=2 ™| isitle
— Lozation
o | i |

Text Style: I[Default] vI Te:-ttSters...l
Raotation: I

I | Flipped

Justification

[N O
[N O
& CoC

, . , . Place Attribute
Add >  Sélectionner [’attribut
Attribute Cat : Marne: Marne:
Clearance Clearance et entrer la dattattd e e
.. ’. . Al dttributes Lzer-defined |Elearance
valeur choisie pour l’isolement ( voir | |Component w
. N Met LineToLineClearance  Yalue:
exemple cz—contre) OK Clearance PadToLineClearance | [ mm
Fiouter PadT oPadClearance
SPECCTRA Route YialoLineClearance

SPECCTRA Placement . |%iaToPadClearance
YiaT oviaClearance I wizible

— Location

Remargue : on peut différencier si on % v
le désire les isolements ( piste a piste,

piste & pastille ... ) Tod St [Doi ] Torooie |
Rotation: I

I | Flipped

Justification

(SN G
o CC
[ G

agK I Cancel
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La fenetre  cl-comtre oIt alors

apparaitre : Attributes

M ame: Walue
Valider par OK m

Clearance 0.5mm

Remarque: on  peut  obtenir
exactement le méme résultat en
ajoutant les attributs sur les nets sous
Accel Schéma.

Delete | Properties. .. |

Ok | Canicel |

Définition de la largeur des nets particuliers :

Sélectionner le ou les nets dans la liste : exemple ci-dessous GND et VCC ( appuyer sur la touche CRTL
pour une sélection multiple ) > Edit_Attrs > Sélectionner [’attribut a modifier, exemple Width >
Properties 2> Modifier la valeur > OK > Vérifier I'affichage de la modification > OK

EditNets |
Renouveler pour tous les nets de largeurs o
différentes (ou d’isolements différents ) -

Eerame...

|,

Edit Attrs. .

Wiew Attrs...

FRELL

Show Conns

Shaow Conng
Only On Drag

Hide Conns

Set All Mets

Highlight i e ede

Urhighlight Set Mets By Altr...

Clear All Mets

il

I
I
I
Select Set Metzs By Mode Count | Hir: I b

Close

& Optimiser le chevelu :

Il est intéressant d’optimiser les nets afin de réduire les longueurs des connexions. On peut également
autoriser le logiciel a interchanger ( swapping ) par exemple les portes logiques utilisées ou les broches

des composants.
p Utils Optimize Nets

Utils > Optimize Nets > Choisir les options a | M=hed Auta Dptions

valider 2 OK ' Auto W Gate Swap  © Entire Design
™ Manual Gate Swap

" Manual Fin Swap Iv| inSwap €1 Sefected HhiEcts

(] I Cancel
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© Enregistrer le fichier prét au routage

File & Save ou n

Le fichier est alors sauvegardé¢ avec les configurations de routage.

O Routage automatique a I’aide du logiciel « PCAD2001 Shape Route »

£ Dans PCAD2001 « PCB » cliquez sur « Route » e gremmmmmree

puis « Autorouters... » rm
Yiew Log !

tanual
Interactive
Iiter
. A Bus
Un Warning apparait : MuliTrace
Warning 9559 Fanout
/' The fallowing files will be ovensuntten:

- C:\Document Wordy1 STIGEM construction’Evaluation n 34T upontRCompf.pch
C:ADocument 'Wwordy1 STIGEM conzstruction’Evaluation n 35TwpontRCompf LOG
CADocument Wordy1 STI GEM construction’E valuation n 35T yponCompf. PRF

[ro wou want to continue?

Cliquez sur « Oui ».

La fenétre suivante apparait :

FEl P-CAD 2001 Shape-Bazed RBouter - [C:ADocument Wordi1 5T1 GEN conzir._. [H[=] E3

File Edit “iew Toolz Option: RBeportzs Help

=lalale o ols] ©
NN

Votre circuit prét a
router

&5 Véritiez les options du Router :

. . [pki epaorts He
Cliquez sur « Option » et « Atorouter » @
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La fenétre suivante apparait, Cliquez sur « Parameters », vérifiez et modifiez les paramétres du router :

Si TOP est noté Disabled alors vous
étes bien en simple face

Autorouter Setup

Routing Passes  Parameters JaPe=inaints I

/
Router Parameters /
"]

-
Layer Route Direction J/ Urits: |Mils & Y!
Top Disabled Ve Yia Type: IThruhoIe DnIG"
Battarn Auta
Channel: IED 5 i
Yias UnderSMD:lNo vi

L’unité doit étre en

11 doit étre affiché « No via »

La largeur de piste doit étre la méme

Primary Pad Size: [118.11024
rmary Pad Size que celle que vous avez configurez
Frimary Yia W’|dth:|4D sous « PCB »

L
Frimary Trace %idth: |39.3?DDS <4

Piimay Clestance:[13 68504 4 <«—— | L’espace entre pistes, pastilles et bord,
doit étre le méme que celui configuré

Analyze Directions I SOUS « PCB »

Ok I Cancel | Help |

&5 Outil disponible du router :

Ces outils sont disponibles en cliquant sur « Tools ». Choisissez si vous en avez besoin, dans la liste
suivante :

|Il:||:||$ Optionz  Beporte H

Start Autarouter
Siem A utaraiter

Eause Sutarauter
Bestart Awtorouter

Autoroute Connectioh < Route les pistes que vous désignerez

Autoroute Met < Route toutes les pistes connectées a un composant que vous désignerez
Autorgute Compongnt < Route toutes les pistes connectées a une pastille que vous désignerez
Autoroute Area < Route toutes les piste d’une aire que vous délimiterez

Sketch Route

Manual Route

Unroute All Hats € Annule toutes les opérations de routage.

Unroute Conflicts < Annule les opérations de routage effectué sur un conflit
Unroute Met < Annule le routage effectué sur une piste que vous

Unroute Connection < Annule le routage effectué sur une pastille que vous
Unroute Segment < Annule le routage effectué sur un segment que vous

25 Quittez et Sauvegarder :
Pour revenir sous PCB, cliquez sur « File » et « Save and return » :

\

File Edit “iew Yools L
Save and Return

Frrint...
Frint Setup...

Festore AutoSave
Make AutoSave
AutoSave [nterval...

E =it

pcad 2001



@ Mettre d’une pastille

Cliquez sur I’icone : « (ﬂl » et positionner le centre de la pastille sur votre circuit.

O Changer la taille d’une pastille

Cliquez sur I’icone « L3 | » et sélectionnez la pastille a modifier.

Cliquez sur le bouton droit de la souris et sélectionnez « Pad Properties » ; La fenétre suivante apparait :

Pad Properties
Options Pad Style
—Location Cliquez sur Current Style:  pastei
Wet Mame: P d St 1
¥ i D efault
Padtumber o 71.120 106 §; a yles [EI | LI
DefautPn - [~ [ Fied {metm E:EEE‘I ity i)
L Rsar o ) PEXBIVEOD 384
Pad Style: Pad Style: I= [ Fip P:ExEOVEOD 3 Modify [Complex]...
2 \
Taol Code: Rotation: Uldeg \ el
Birge Whiised St
rondcuiy
rondouiy [1]
ronde-d1 50
* pastci odify Hole Range
oK I Cancel I
Close |
Copy Pad Style
Pad Mame: v
Copy OF: =00_80_20 =] N
bRl \ Donnez un nouveau nom a
rondcuiv . ,
randeiv [1] la pastille que vous créez et
ronde-d150 :
20 80 20 _— cliquez sur « OK »

Cancel |

Vous revenez automatiquement sur la fenétre « Option Pad Style ».
Sélectionnez le nouveau nom de pastille et cliquez sur « Modify (Complex)... » :

Maodify Pad Style [Complex]

Cliquez d’abord sur « Top », ~ Narme: vis Hoe
modifiez la largeur (« Width »), la Layers: ~ Pad Definition D';"_f_“e‘e“ [0:508mm
. T _ v | Elated
hauteur (« Height ») et la forme I Layer: Top z e
: ottom ¥ Offset. [0.000
(« Shape ») de la pastille en (Gignal ‘Wi [2.000mm - —
fonction de ce que vous voulez. {E';‘Qgi]g] Height: e ¥ Offset. [0.000mm
Cliquez sur Modify. o ~Plane Swell
4 , Y= Spckewidtr (00 panLT WGF; o
Recommencez I’ opération pour —~— Use Global Swe
Bottom en cliquant dessus . T~ Shene L= syl [0000mm
-RWD%B[ Pour Cannections e
oK
4dd | “Modfy | Delete | e
Cancel |

Une fois ces opérations effectués, cliquez sur OK et vous reviendrez sur la fenétre « Option Pad Style ».
Cliquez sur « Close » et vous reviendrez automatiquement sur la fenétre « Pad Properties ».
En face de « Pad Style » sélectionnez votre pastille nouvellement créée et cliquez sur « OK ».

—_——
Pad Style: pastei o ’ Pad Styles |
ronde-d150 e
Tool Code: | P 53R0vEND 384 [1
rondcuiy [1]
Cl
HEOYEOD 384 [1
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© Imprimer les résultats
Pour imprimer le typon

File > Print - Setup Print Jobs = Valider les options correspondant a la fenétre ci-dessous ( pour

une sélection des 2 couches bottom et board, appuyer sur la touche CRTL ) et compléter la case Print Job

Name -> Apply Laver Set > Add ( ou modify ) = Close - Generate Printouts

Setup Print Jobs |
Frint Jobs: — Print Job Selections ; ;
Frint Job M ame: ITVF'DN e i
Layers: — Print Adjustments r B.otate
F‘p ’S*"Slil" [ Scale to Fit Page I Miror
op Si
Tgp Paste Ccale; I‘lDD I_ Dra_ft
Top Mask _ [T RefDes
To # offset: IEI.DEImm [ i
Baot Mask ' offzet: IEI.DEImm [ Walue
Bot Paste ¥ Pads
gc't 2'"* — Prirt Reqgion I vias
oL v Design Extents —
v FadAia Holes
T E— o % Paciviakio
Wefine fegion | [" Pick and Place
Lower Left Corner: ; Gilue Dot
Keepout
- |25.25rnrn -
S “ [ Cutouts
t
;l i |25.25mm B EsiesTs
£dd | Clear &l I |Upper Right Carmer: [ Dill Sy
b aify | Apply Layer Set | - I,‘rg_ggmm Drill Sym size:

Delete |

| =

v |63.65mm

|2.I33mrn

Cloze

Pour imprimer le plan d’implantation des composants :

File > Print - Setup Print Jobs = Valider les options correspondant a la fenétre ci-dessous ( pour
une sélection des 2 couches bottom et board, appuyer sur la touche CRTL ) et compléter la case Print Job
Name > Apply Laver Set > Add ( ou modify ) 2> Close - Generate Printouts

Setup Print Jobs |

Frint Jobs: — Frint Job Selections _ .
EYPDN Prirt Job Mame: IMPLAMT - Display Options

Layers: — Print Adjustments r E'.jtate

Top Ass [T Scale to Fit Page :: Mirror

Diratt

Top Paste Scale: |1 .o -

Top Mask ¥ RefDes

égﬁ = offset: ID.DDmm o

attam

Bot Mazk ' offzet: ID.DDmm v Walue

Bat P§$te I Pad

Bt Silk. — Print Reaion [ yias

Bot -"-\$$i —e [V Design Extents

Wefire Heammn

[T Padfvia Holes
I Pick and Place

Lower Left Comer: :: Glue Dt
Keepout
- |25.25mm ~
— A [ Cutouts
[
& _I it |25.25mm ¥ Caonnections

L

Aadd | Clear &1 | Upper Right Carner: ™ Dl Sym
Modity | | |£ Apply Layer 8ai )| | v [72 &amm Dril Sy size:

|2.I33mm

peiste | || =] | v [63.55mm
Cloge |
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